๐Ÿ‘‰ Hoe maak je oude WordPress-thema's compatibel met nieuwe versies - IsItWP

Heeft de WordPress-beheerdersbalk een vervolgkeuzemenu nodig?

>

Dus je wilt je oude WordPress-thema's compatibel maken met nieuwere versies van WordPress. Met WordPress 3.0 om de hoek is thema-compatibiliteit iets voor veel mensen. Het is vrij eenvoudig: helemaal niets doen.

Ik heb WordPress-thema's gemaakt sinds WordPress 2.3 werd uitgebracht en wat denk je? Die thema's nog steeds werken vandaag en er is niets dat ik nodig hebben doen om ervoor te zorgen dat ze blijven werken met nieuwere versies van WordPress.

  • Zullen ze hebben commentaarfunctionaliteit met schroefdraad (circa 2,7)? Nee, ze hebben waarschijnlijk nog steeds "single level" commentaren.
  • Zal het gebruiken post_thumbnails om postminiaturen te verwerken (circa 2.9)? Nee, maar niet elk thema maakt toch gebruik van postminiaturen.
  • Zullen zij het nieuwe hebben navigatiemenu's, aangepaste header- en achtergrondafbeeldingen geïntroduceerd in de komende WordPress 3.0? Nee, en onthoud dat niet elk thema een aangepaste achtergrond of headerafbeeldingen nodig heeft.

De meeste van deze functies zou ik als optioneel beschouwen. Met misschien de uitzondering van commentaren met schroefdraad of het nieuwe menusysteem, zullen veel thema's niet eens nodig zijn of worden ontworpen rond dingen zoals aangepaste berichtminiaturen of koptekstafbeeldingen.

Dus stop alsjeblieft je niet langer als je thema gaat breken wanneer je een upgrade van WordPress uitvoert. Geen aanstoot aan mijn plugin-ontwikkelaarsvrienden, maar 99% van de tijd breekt WordPress met een kernupgrade, het is de fout van een plug-in (en waarschijnlijk kwam deze door verdachte plugin-codeerpraktijken).

Als een thema een aangepaste functie heeft die conflicteert met een nieuwe WordPress-functie, kan hetzelfde ook gebeuren met thema's, dus het is mogelijk. Dit is waarschijnlijk de enige "bug" waarvan ik ooit heb gehoord dat het gebeurt met een nieuwe core-upgrade (en niet elk thema gebruikte de functie get_categories).

Om eerlijk te zijn, Ik heb nog nooit een thema volledig zien brekenen dat zal ik waarschijnlijk nooit doen. Ik zou graag uw mening horen in de reacties, wat vindt u ervan om thema's "compatibel" te maken met nieuwe versies? Heb je ooit een thema-onderbreking gezien vanwege een nieuwe WordPress-versie?

Als u wilt dat uw WordPress-thema profiteert van de nieuwe functies die beschikbaar zijn zodra WordPress 3.0 is uitgebracht, bevat dit artikel goede informatie over het integreren van aangepaste achtergronden, koppen, menu's, enzovoort.

Like this post? Please share to your friends:
Geef een reactie

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: